Aide du logiciel Contour version 9.3




Présentation

Lancement des deux modules du logiciel

Menus de jeu

Menus d'édition


Présentation

Ce logiciel utilisable dès 4 ans permet aux utilisateurs de découvrir la suite numérique écrite, d'apprendre à compter et à utiliser la souris ou le pavé numérique.
L'utilisateur doit relier les points consécutifs pour découvrir une image. 

Le logiciel peut être utilisé pour travailler des suites numériques.

L'utilisation du contour d'un détail caractéristique d'une image connue des enfants permet l'émission d'hypothèses sur la nature de l'image.

Fenêtre d'accueil de Contour et fenêtre de jeu : 

fenêtre principale  jeu
Le jeu consiste à relier les points en les survolant avec la souris dans l'ordre pour faire apparaître le contour de l'image. Une fois le contour achevé, l'image apparaît.

Lancement des deux modules du logiciel

Abuledu-contour présente deux modules : un module de jeu et un module d'édition pour créer des contenus pour le précédent.

Dans sa version Debian l'installation du logiciel crée 2 entrées dans le menu Education et 2 icones sur le bureau.

Pour lancer le logiciel abuledu-contour, double-cliquer sur le fichier contour.tcl contenu dans le dossier d'installation du logiciel abuledu-contour. Une fenêtre vous proposant de lancer "contour.tcl" s'ouvre comme sur l'image ci-contre :
Cliquer sur le bouton Lancer.

Remarque :
Pour les testeurs le bouton Lancer dans un terminal permet d'avoir accès à des informations supplémentaire sur le fonctionnement du logiciel.
Pour les développeurs, le bouton Afficher permet de lire le contenu du fichier.


Rappel : quel que soit le système d'exploitation, l'interpréteur Tcl/Tk doit être installé.
lancement de contour

Menus du premier module : le jeu contour


Le menu Fichier permet uniquement de quitter le logiciel.

Le menu Images permet le choix d'une image.

Le menu Réglages permet d'accéder aux réglages décrits ci-dessous.

Le menu Aide 

menus
Images

Les images paramétrées pour le logiciel "Contour" sont enregistrées dans le dossier "images" du dossier d'installation "abuledu-contour".
Ci-contre le menu déroulant permettant de choisir une image en cliquant sur le nom du fichier :

Les images disponibles pour le jeu contour doivent avoir été paramétrées préalablement avec le module d'édition de contour et enregistrées dans le dossier "images" en utilisant le gestionnaire d'images.

Une fois qu'une image est choisie la fenêtre de jeu s'ouvre.
menu images

Réglages

Ce menu permet de définir : 

  • différents paramètres :
    • le choix de Dossiers images qui permettra le choix d'une image par le menu Images,
    • la Taille des numéros correspondant aux points à relier pour éviter que les grands nombres se chevauchent,
    • l'Epaisseur des traits pour modifier la visibilité du contour,
    • La Couleur des traits et des numéros pour être visible selon l'image choisie,
    • le Numéro de départ dans la suite des nombres qui définit le contour,
    • le Pas de progression qui peut être défini par un nombre. Ceci permet de définir une suite arithmétique dont la raison est le pas de progression.
  • les modalités de liaison des points par le sous-menu Souris. Les modalités pour relier les points sont au nombre de 4, de la plus simple à la plus complexe :
    • Survoler : il s'agit de déplacer la souris au dessus des points,
    • Cliquer : il est nécessaire de cliquer sur chaque point,
    • Double-cliquer : il est nécessaire de cliquer 2 fois sur chaques points,
    • Pas de souris : oblige à utiliser le pavé numérique, chaque nombre est saisi au clavier puis taper la touche "Entrée". Les points ne sont pas numérotés dans cette activité, il est donc nécessaire de connaître l'écriture chiffrée de la comptine numérique.
  • la langue des menus dans "Contour" par le sous-menu Langue

menu réglages


  Aide

Ce menu permet d'accéder à cette aide qui s'ouvre dans un navigateur, ainsi qu'aux sous-menus :

Menus du deuxième module : l'éditeur

L'éditeur de Contour permet de créer des contours d'images.

L'éditeur est accessible en lançant le fichier editeur_contour.tcl présent dans le fichier d'installation du logiciel abuledu-devine ou par le raccourci présent dans l'onglet Education.

Il n'y a pas de menu "images" car il est intégré au menu Fichier

Cliquer sur Fichier  qui propose :

editeur

menu fichier editeur

Pour ouvrir une image présente dans un emplacement précis de votre ordinateur cliquer sur Ouvrir

Il faut alors choisir une image en utilisant le navigateur de dossier de votre système. Utilisez des images convenablement modifiées à l'aide d'un logiciel de retouche d'images, par exemple the GIMP. Choisissez de préférence le format d'images jpg. Mais vous pouvez utiliser aussi png ou gif. Les ratios longueur / largeur de 3/2 et 4/3 paraissent satisfaisants, comme par exemple des images au format 600x400.
Il est ensuite possible de créer un contour d'image.

Pour ouvrir directement une image contenue dans le logiciel contour cliquer sur Ouvrir une image du dossier vrac.

Ce logiciel comporte un menu de gestion des images accessible par Gérer les dossiers et les images.

Dans ce menu en cliquant sur Exécuter Contour il est possible de lancer directement l'application. La nouvelle image paramétrée est alors disponible.
Gestion des images

1
 
Nommer un dossier et 2 l'ajouter
Ajouter des images en choisissant le dossier source à gauche et le dossier destination à droite puis en cliquant sur Ajouter.
4 Effacer des dossiers ou des images d'un dossier en choisissant le dossier concerné et en cliquant sur le bouton Effacer.

tag Après un ajout ou un effacement, quel qu'il soit,
vous devez impérativement fermer l'application et la relancer
pour que les modifications soient prises en compte.
Sinon, le comportement de cette application peut sembler étrange.


gestion images

Créer un contour d'image :


Il suffit de cliquer sur l'image pour définir un point. La numérotation est automatique. Si les nombres sont peu visibles sur le fond de l'image choisie il peut être utile de changer leur couleur et leur taille dans les réglages. 
attention Les choix des paramètres doivent se faire avant de tracer le contour pour être pris en compte. 
 
Le type d'activité peut également être modifié par les réglages.
Ces réglages peuvent être imposés sinon ils pourront être modifier dans le jeu.

Dans l'exemple ci-contre les paramètres choisis dans le menu réglages sont la couleur rouge et la taille 16 pour les nombres et le trait rouge pour le contour.

Pour tracer le contour des yeux sans le relier au reste il est nécessaire d'utiliser le bouton "trait discontinu" :trait discontinu
Il est possible  de cliquer sur la gomme pour effacer autant de point qu'on le souhaite en partant du dernier tracé.gomme
Le pouce permet de visualiser le tracé mais attention, seulement à la fin ! pouce

Pour enregistrer et quitter l'image, cliquer sur la porte :  quitter

L'image est enregistrée dans son dossier d'origine avec le nom du fichier d'origine. Il est nécessaire de choisir ce dossier dans le jeu contour pour accéder à cette image par le menu Images.

Le résultat du contour : contour fini
créer un contour

Imposer les réglages
Dans le module d'édition les paramètres sont les mêmes que dans le menu réglages du jeu à l'exception du choix d'imposer un réglage ou pas : 

attention Il est possible d'Imposer les réglages définis dans l'éditeur pour un contour donné pour que l'utilisateur ne modifie pas ces réglages. imposer


Haut de page